Running ngdbuild

Need some help on a project you are working on or got stuck on a tutorial? Post your questions here.
Post Reply
racsom
Posts: 1
Joined: March 22nd, 2018, 1:54 am

Running ngdbuild

Post by racsom » March 22nd, 2018, 1:58 am

I am trying to build the first model after installing ISE and the IDE. I have windows 10 and did the whole switch of dll files and adding the -m32 to the command in order to get the environment started. However as soon as I try to build the LED example, the build gets stuck. Here is where it gets stuck. The ngdbuild command is just sitting there. I am new to all of this and I haven't found anything that shows what I could be doing wrong. Any help would be appreciated.

Thanks.

.....

ngc2edif: Total memory usage is 112716 kilobytes



Parsing EDIF File [C:/Users/racso/OneDrive/Documents/mojo/LEDtoButton/work/planAhead/LEDtoButton/LEDtoButton.data/cache/mojo_top_0_ngc_zx.edif]
Finished Parsing EDIF File [C:/Users/racso/OneDrive/Documents/mojo/LEDtoButton/work/planAhead/LEDtoButton/LEDtoButton.data/cache/mojo_top_0_ngc_zx.edif]
INFO: [Netlist 29-17] Analyzing 1 Unisim elements for replacement
INFO: [Netlist 29-28] Unisim Transformation completed in 0 CPU seconds
Loading clock regions from C:/Xilinx/14.7/ISE_DS/PlanAhead/data\parts/xilinx/spartan6/spartan6lx/xc6slx9/ClockRegion.xml
Loading clock buffers from C:/Xilinx/14.7/ISE_DS/PlanAhead/data\parts/xilinx/spartan6/spartan6lx/xc6slx9/ClockBuffers.xml
Loading package pin functions from C:/Xilinx/14.7/ISE_DS/PlanAhead/data\parts/xilinx/spartan6/PinFunctions.xml...
Loading package from C:/Xilinx/14.7/ISE_DS/PlanAhead/data\parts/xilinx/spartan6/spartan6lx/xc6slx9/tqg144/Package.xml
Loading io standards from C:/Xilinx/14.7/ISE_DS/PlanAhead/data\./parts/xilinx/spartan6/IOStandards.xml
Loading device configuration modes from C:/Xilinx/14.7/ISE_DS/PlanAhead/data\parts/xilinx/spartan6/ConfigModes.xml
Loading list of drcs for the architecture : C:/Xilinx/14.7/ISE_DS/PlanAhead/data\./parts/xilinx/spartan6/drc.xml
Parsing UCF File [C:/Users/racso/OneDrive/Documents/mojo/LEDtoButton/work/planAhead/LEDtoButton/LEDtoButton.srcs/constrs_1/imports/components/mojo.ucf]
Finished Parsing UCF File [C:/Users/racso/OneDrive/Documents/mojo/LEDtoButton/work/planAhead/LEDtoButton/LEDtoButton.srcs/constrs_1/imports/components/mojo.ucf]
[Wed Mar 21 22:58:02 2018] Launched impl_1...
Run output will be captured here: C:/Users/racso/OneDrive/Documents/mojo/LEDtoButton/work/planAhead/LEDtoButton/LEDtoButton.runs/impl_1/runme.log
launch_runs: Time (s): elapsed = 00:00:13 . Memory (MB): peak = 302.117 ; gain = 81.762
# wait_on_run impl_1
[Wed Mar 21 22:58:02 2018] Waiting for impl_1 to finish...

*** Running ngdbuild
with args -intstyle ise -p xc6slx9tqg144-2 -dd _ngo -uc "mojo_top_0.ucf" "mojo_top_0.edf"

embmicro
Site Admin
Posts: 834
Joined: March 24th, 2013, 12:45 pm

Re: Running ngdbuild

Post by embmicro » April 4th, 2018, 10:27 am

I haven't seen anyone run into this issue yet. Does it happen with any project? Have you tried rebooting?

Post Reply