Trouble using avr interface

Projects you are planning or working on with the Mojo
Post Reply
hanut
Posts: 10
Joined: January 25th, 2015, 6:12 pm

Trouble using avr interface

Post by hanut » November 23rd, 2015, 3:30 pm

Hi,
I was implementing a project that fetches data from the RAM and sends it through the avr, via the usb port to the serial port.
However, i get this error while implementing
ERROR:NgdBuild:604 - logical block 'avr_interface' with type 'avr_interface'
could not be resolved. A pin name misspelling can cause this, a missing edif
or ngc file, case mismatch between the block name and the edif or ngc file
name, or the misspelling of a type name. Symbol 'avr_interface' is not
supported in target 'spartan6'.
ERROR:NgdBuild:924 - input pad net 'clk' is driving non-buffer primitives:


Please advise regarding the same!

Thanks
Hanut

embmicro
Site Admin
Posts: 834
Joined: March 24th, 2013, 12:45 pm

Re: Trouble using avr interface

Post by embmicro » November 24th, 2015, 1:40 pm

Without seeing your project it's hard to know exactly what's going on.

The first error looks like the avr_interface module is missing from your project.

The second error is likely because you are trying to use the PLL in the FPGA to generate a 100MHz clock from clk but also trying to use clk directly (I don't believe this is allowed). If you need both 100MHz and 50Mhz, you need to change the clock wizard settings to output both frequencies.

hanut
Posts: 10
Joined: January 25th, 2015, 6:12 pm

Re: Trouble using avr interface

Post by hanut » November 24th, 2015, 2:39 pm

Thanks for the advice.
Ill check it on the code and post later.
As for the code, is there anyway i can send you a copy of the files privately?
It would be helpful for my project.


Thanks

Hanut

embmicro
Site Admin
Posts: 834
Joined: March 24th, 2013, 12:45 pm

Re: Trouble using avr interface

Post by embmicro » December 1st, 2015, 2:15 pm

If you can't post them publicly here, you can email me at support@embeddedmicro.com

Post Reply